If you're struggling to install fail2ban and being notified that the package cannot be found, you simply need to enable the universe repository and update the package list.

sudo add-apt-repository universe

sudo apt update

sudo apt install fail2ban